[URWIGO] Problème de Timer.

Section dédié à la gestion de ces caches un peu particulières...
Avatar du membre
crow dog
nano-cacheur
nano-cacheur
Profil GC
Membre: : Premium
GPS : Garmin Etrex 35 + Samsung S8
Messages : 18
Enregistré le : jeu. 30 août 2018 10:09

[URWIGO] Problème de Timer.

dim. 16 sept. 2018 11:28

Bonjour,

Voila j'ai publié une première wherigo, assez simple (un quizz jouable en mode play anywhere).
Maintenant, je m'attaque à une nouvelle, type aventure, avec des zones à parcourir.
A un moment, entre la sortie d'une zone et l'entrée dans la suivante, j'ai installé un timer.
S'il dépasse le temps imparti, le joueur devra recommencer ou sinon il pourra continuer l'aventure.

Le problème est que quelque soit le temps mis par le joueur pour allez de la zone X à la zonne X+1, cela se solde toujours par une réussite !
J'ai testé le cartouche (fiche gwc) sur le terrain en pensant que le simulateur urwigo ne prend pas en compte le paramètre temps mais idem toujours une réussite comme résultat.

Voici comment j'ai procédé :
Création d'un timer (nommé Chrono) : type countdown, duration 180, events : néant pour les 3 options.
A la sortie de ma zone X : on exit handled : start timer Chrono
A l'entrée de ma zone X+1 : en enter handled : stop timer Chrono, if/else, if Compare Chrono.Elapsed<=60 ---> message bravo
ET if Compare Chrono.Elapsed>60 --> message echec.

C'est peut-être un problème avec les activation/désactivation des zones (en sortie ou en entrée) ou un réglage des options du timer ?
Svp, si quelqu'un peut me donner un petit coup de pouce se serait bien sympa. Par avance merci.

Bon dimanche.
Image
Avatar du membre
TofLaBeuze
Administrateur du site
Administrateur du site
Contact :
Profil GC
Membre: : Premium
GPS : Samsung J5 + Etrex 30x
Localisation : Paris
Messages : 6602
Enregistré le : sam. 22 oct. 2011 12:35

Re: [URWIGO] Problème de Timer.

dim. 16 sept. 2018 14:56

Hello,
il ne faut pas tester le chrono.elapsed. tu gères 2 événements :
- zone2.OnEnter : ici c'est gagné
- timer.OnElapsed : ici c'est perdu

N'hésite pas si ce n'est pas clair !
Image Image
Avatar du membre
crow dog
nano-cacheur
nano-cacheur
Profil GC
Membre: : Premium
GPS : Garmin Etrex 35 + Samsung S8
Messages : 18
Enregistré le : jeu. 30 août 2018 10:09

Re: [URWIGO] Problème de Timer.

dim. 16 sept. 2018 19:03

--
Modifié en dernier par crow dog le mar. 18 sept. 2018 13:25, modifié 1 fois.
Image
Avatar du membre
crow dog
nano-cacheur
nano-cacheur
Profil GC
Membre: : Premium
GPS : Garmin Etrex 35 + Samsung S8
Messages : 18
Enregistré le : jeu. 30 août 2018 10:09

Re: [URWIGO] Problème de Timer.

mar. 18 sept. 2018 13:24

TofLaBeuze a écrit :Hello,
il ne faut pas tester le chrono.elapsed. tu gères 2 événements :
- zone2.OnEnter : ici c'est gagné
- timer.OnElapsed : ici c'est perdu

N'hésite pas si ce n'est pas clair !
Bonjour TofLaBeuze,

Après analyse, il y a une faille avec ce système (c'est moi qui n'est pas compris où placer le Start.Chrono), à savoir qu'un joueur peut ne pas déclencher le chrono en ne cliquant pas sur l'événement dans la zone1 (bouton OK suite au message "commencez à courir"). Il peut alors tranquillement aller dans la zone2 (zone2.OnEnter) et cliquer pour déclencher le chrono et … qui s'arrêtera aussitôt sur une réussite bien sûr.

Pour palier à ce problème, j'ai pensé, comme initialement forcer le démarrage du chrono lorsque le joueur quitte la zone 1 et ce, en plaçant Start.Chrono dans Zone1.OnExit Handled (au lieu de Zone1.OnEnter) … mais seulement cela ne fonctionne malheureusement pas, la fonction timer.OnElapsed ne se déclenche jamais :(. Je ne comprends pas pourquoi … je pense qu'il s'agit peut être d'un problème d' activation et de désactivation des zones 1 et 2 (ou d'un problème de display).

Svp, si tu as une solution à proposer je suis preneur. Par avance merci.
Image
Avatar du membre
TofLaBeuze
Administrateur du site
Administrateur du site
Contact :
Profil GC
Membre: : Premium
GPS : Samsung J5 + Etrex 30x
Localisation : Paris
Messages : 6602
Enregistré le : sam. 22 oct. 2011 12:35

Re: [URWIGO] Problème de Timer.

mar. 18 sept. 2018 13:49

Tu ne peux pas déclencher ton timer juste avant ton message "commencez à courir" ?

Un start chrono dans le OnExit fonctionne bien. N'aurais tu pas désactivé la zone avant le start chrono en effet ?
Image Image
Avatar du membre
crow dog
nano-cacheur
nano-cacheur
Profil GC
Membre: : Premium
GPS : Garmin Etrex 35 + Samsung S8
Messages : 18
Enregistré le : jeu. 30 août 2018 10:09

Re: [URWIGO] Problème de Timer.

mar. 18 sept. 2018 16:48

TofLaBeuze a écrit : Un start chrono dans le OnExit fonctionne bien. N'aurais tu pas désactivé la zone avant le start chrono en effet ?
En effet, je suis con.
Il faut vraiment penser à tout.

Merci.
Image

Retourner vers « Caches Wherigo »

Aller à ...

Annuaire

annuaire geocaching

Éditeur HTML

editeur HTML

Galerie des concours

galerie photos

Inscription Newsletter

newsletter

 

Au total il y a 48 utilisateurs en ligne : 3 enregistrés, 0 invisible et 45 invités
Membres : Bing [Bot], CIOL64, Google [Bot]
Le record du nombre d’utilisateurs en ligne est de 384, le ven. 19 sept. 2014 19:40
89102 messages
6800 sujets
4764 membres
Le membre enregistré le plus récent est phil83000.
Pas d’anniversaire à fêter aujourd’hui